Page 1 of 1

[solved] no sound output in opensuse 15.2

Posted: Sun Jun 13, 2021 6:12 pm
by ag123
hi i'm a newbie here, i need some help as several attempts to try out lmms produce no audio output
i'm running Opensuse 15.2 linux 64 x86_64 kernel 4.12.14-lp151.28.91-default #1 SMP

I've installed lmms from the releases found in github
i tried the lmms-1.2.2-linux-x86_64.AppImage
as well as the latest alpha
but both of them did not produce any sound output.

In settings:
Audio interface selected is :
i tried the rest namely
Alsa, SDL and pulseaudio (this is the main audio interface and other apps including the web browser (firefox) works and is able to produce sound)

the attempt is to go into the default tripleoscillator and click on the keyboard.
it produce keypress sound animination on the FX Mixer but no sound is heard, this is the same even if i move the master volume slider to the max
has anyone encountered the same and found a solution ?

thanks in advance.

Re: [solved] no sound output in opensuse 15.2

Posted: Mon Jun 14, 2021 7:39 pm
by ag123
i solved it, the solution is to use jack instead
i ran into quite a lot of trouble getting jack / jackd to work correctly
but once jack is able to send sound to the alsa layer beneath, i connect lmms to jack and i'm now hearing sounds from lmms
normally the connection to jack is 'automatically' setup if you select jack in settings > audio settings

this means you'd need to first install jack audio kit (server)
to connect lmms and jack the recommended tool is qjackctl. this provides a convenient way to visualize the connections
both these 2 tools are found in opensuse distribution and i think i'd be found in other linux distributions too

hope this helps anyone troubleshooting sound issues