ZynAddSubFX not working

Having trouble with LMMS? Ask about it here.
I'm sure I didn't have any issue with ZynAddSubFX a week ago (can't tell for sure after that, didn't have time to use LMMS), but now when I use a ZynAddSubFX instrument I have issues. First of all, on a project I was working on, the sounds are all correct, but when I try to change a parameter in any of the ZynAddSubFX instruments, the sound changes completely (changing the frequency and putting it back to how it was changes the sound a lot). Trying to open the GUI just mutes the instrument and opens nothing. I tried adding a new ZynAddSubFX instrument on an empty project and there again, it works fine until you try to change a parameter or enter the GUI. This time however, when I tried to enter the GUI I got 3 RemoteZynAddSubFx.exe - System Errors :

1) The code execution cannot proceed because libfltk.dll was not found. Reinstalling the program may fix this problem.

2) The code execution cannot proceed because Qt5Core.dll was not found. Reinstalling the program may fix this problem.

3) The code execution cannot proceed because libwinpthread-1.dll was not found. Reinstalling the program may fix this problem.


Additionally, not sure if it's worth mentioning but I got some errors in my current project saying it couldn't load GSnap and GTune. I didn't even remember using them and deleting unused instruments removed this error message
AnthonyB wrote:
Sun Oct 13, 2019 5:07 pm
3 RemoteZynAddSubFx.exe - System Errors :
1) The code execution cannot proceed because libfltk.dll was not found. Reinstalling the program may fix this problem.
2) The code execution cannot proceed because Qt5Core.dll was not found. Reinstalling the program may fix this problem.
3) The code execution cannot proceed because libwinpthread-1.dll was not found. Reinstalling the program may fix this problem.
errors in my current project saying it couldn't load GSnap and GTune. I didn't even remember using them and deleting unused instruments removed this error message
Sounds to me like you have changed your library structure on your pc (?)
Have you installed something recently?
Some game-demos, are very rudely messing up your system..
My advise is to do a new installation, because you have obviously lost files.
Follow:
"Updating and installing new versions"
On this page:
https://lmms.io/wiki/index.php?title=Installing_LMMS
The only thing I had to reinstall was Kaspersky Internet Security. I guess that this somehow messed up my library, as you said. If I reinstall LMMS, will I still have my files or should I save them before?

Who is online

In total there are 19 users online :: 0 registered, 0 hidden and 19 guests (based on users active over the past 5 minutes)
Most users ever online was 238 on Wed Oct 23, 2019 11:40 am

Users browsing this forum: No registered users and 19 guests