First VST doesn't work

Having trouble with LMMS? Ask about it here.
Dear all,
thank you for this masterpiece of software!!!

After working in lmms for a while, I started to create a small vst to monitor some midi signals.
Just a small vst.
I used SynthEdit 64 Bit for that.
The VST is loading very well with VeSTige and seems to work. BUT no midi information is transfered.
idk why.
im working on LMMS 1.2.0 64Bit windows.

any help or a working synthedit source file would be apreciated.

Thanks id advance,
sincerly yours
First off, Welcome to the Forum sounddev !
Here are all important links:
http://lmms.io/forum/viewtopic.php?f=1&t=4740
-A few rules and useful forum instructions

sounddev wrote:
Tue Oct 08, 2019 6:37 pm
I create a small vst to monitor some midi signals :: In SynthEdit 64 Bit for that.
VST is loading :: BUT no midi information is transfered.
LMMS 1.2.0 64Bit windows.
help or a working synthedit source file would be apreciated.
I doubt you will find the needed help here. You should find a SynthEdit-forum, and you should present your code, there!
However, if you expect LMMS to create MIDI-signals OUT to your VST, then it is not possible yet. LMMS can recieve MIDI-in signals, but cant produce MIDI-out as a response. That is being worked on
Hello musikbear,

thank you for you response.
Well maybe im wrong, but how will a Key played in the Piano Roll be transported to my vst?
I thought that this is a midi signal???

That would explain a lot :D

Maybe someone can help me out here...

best regards
Maybe this helps.

There is MIDI in and MIDI out.

LMMS does not have midi out yet.

Who is online

In total there are 22 users online :: 1 registered, 0 hidden and 21 guests (based on users active over the past 5 minutes)
Most users ever online was 238 on Wed Oct 23, 2019 11:40 am

Users browsing this forum: Google [Bot] and 21 guests