ZynAddSubFX presets won't load

Having trouble with LMMS? Ask about it here.
Hi,

New to LMMS and trying to work my way through a tutorial online to get acquainted. The tutorial is asking me to load a ‘0001-Soft Piano 1’ preset from ZynAddSubFX, but nothing under that folder loads; instead of getting the star icon in front of the preset name as I do in other folders, it just gives me a question mark. I can't drag them into Song-Editor to load. This is a fresh install from the repositories of the distro I'm running on. It also had ZynAddSubFX as a separate package that could be installed, and that seems to work independently of LMMS, but didn't solve my issue. Is there something else I need to do to enable these? I've checked some other tutorials and they all seem to start with the assumption that the presets in the ZynAddSubFX folder are already installed and working.
Mr. Lumbergh wrote:
Tue Oct 08, 2019 5:57 am
Hi, New to LMMS
Hi, Welcome to the Forum Lumbergh!
Here are all important links:
http://lmms.io/forum/viewtopic.php?f=1&t=4740
-A few rules and useful forum instructions

from ZynAddSubFX, nothing under that folder loads; instead of getting the star icon it just gives me a question mark.
ZynAddSubFX (or among friends zasfx:) is part of LMMS-factory-instruments.
All works on Linux and Windows, however not MAC!
Please post your OS and version of LMMS (1.2.0 is newest and only one recommended)
musikbear wrote:
Tue Oct 08, 2019 10:43 am
Mr. Lumbergh wrote:
Tue Oct 08, 2019 5:57 am
Hi, New to LMMS
Hi, Welcome to the Forum Lumbergh!
Thank you. I haven't played with FL Studio much, but this seems to be at least as powerful. I'm looking forward to getting some of my ideas down into music. I have LMMS 1.2.0, fresh as of Sunday night.
musikbear wrote:
Tue Oct 08, 2019 10:43 am
from ZynAddSubFX, nothing under that folder loads; instead of getting the star icon it just gives me a question mark.
ZynAddSubFX (or among friends zasfx:) is part of LMMS-factory-instruments.
All works on Linux and Windows, however not MAC!
Please post your OS and version of LMMS (1.2.0 is newest and only one recommended)
I'll hop over into Synaptic right now and check for that. I'm currently running on PCLinuxOS, but I also have Debian Buster installed on this system and am planning on installing LMMS there too once I free up some space on that drive. I don't care for Ubuntu, but I've started to configure some of the same media optimizations of Ubuntu Studio on Debian to make it into a more solid production environment.
Is there another step to enable LMMS-factory-instruments? It doesn't appear as a separate package in this distro.
Mr. Lumbergh wrote:
Wed Oct 09, 2019 12:03 am
Is there (another) step to enable LMMS-factory-instruments? It doesn't appear as a separate package in this distro.
Qoo... In Linux-1.2.0 AppImage all native instrument should be available without any 'steps' done by user!
Something is wrong!
First check when you press the instrument-button in Sidebar
https://lmms.io/wiki/index.php?title=Side_Bar
if you have this view and all options:
Image

If you do have that, the drag an instance of zasfx into your project with your mouse, then play some notes, that should work as default!

Let us know the outcome :)
I just installed on Debian, and it seems to be working. I'll hop over to the other distro later and see what the deal is there.

Who is online

In total there are 27 users online :: 1 registered, 0 hidden and 26 guests (based on users active over the past 5 minutes)
Most users ever online was 238 on Wed Oct 23, 2019 11:40 am

Users browsing this forum: Google [Bot] and 26 guests