Carla error when trying to run in Windows

Anything that doesn't fit into other topics goes here!
When trying to just run KXStudio Carla 2.2.0 Standalone in Windows 7 Pro (64Bit) I get an error dialog popup.
I was just wondering if anyone else has experienced this?
I have seen that this issue was reported on their GIthub site but it does not seem to have a solution.

I am trying to find out if this is more of a Windows issue or a Carla issue?
I think it is Windows because I have seen other websites for other programs experiencing this.
Does anyone know what Microsoft package this file libstdc++-6.dll can be found in?
I have seen random websites offering this single file to download but I don't want to go that route, usually it is part of an official installer package.

When trying to launch Carla I get a dialog box that reads...
Carla.exe - Entry Point Not Found
The procedure entry point __gxx_personality_sj0 could not be located in the dynamic link library libstdc++-6.dll
then after hitting okay that dialog box closes and a new one pops up that reads...
xc_Freeze: Python error in main script
Traceback (most recent call last):
File ".\lib\, line 14 in run
(4 lines similar to one above)
OSError:[WinError127] The specified procedure could not be found
and then closes and Carla does not launch after.

If anyone has any ideas please let me know.
I have not been able to use Carla in almost a year now
I wonder if discord (LMMS channel) is maybe a better place to ask about this.

I agree you need to be very care full about downloading .dll files from random sites.
Thank you for your response.
I was able to figure it out a little while ago.
Not sure if this is the exact reason but in the past because this is a standalone program I would use it from my D:\ drive.
After new coding around version 2.1.0? this no longer worked.
I unzipped and tried running it from my C:\ drive and it works!!!!
Ahhhhhhhh that it good.
Congrats :)
I figured out some more information on what was causing this error.
I was wrong about it being on a different drive that is not what was causing the issue.
I am using Windows 7 (64Bit) and I was trying to run Carla (32Bit) that is what was causing the issue.
The other day when I got it to work, I loaded the 64 Bit version of Carla which opened perfectly.
When I go to run the 32 Bit version that is when that error comes up about the libstdc++-6.dll file.
I tried this on two machines and they both produced the same results.

Has anyone been able to get Carla 32 to run on Windows 7 64?
Not sure if it is designed to only be able to use 32 Bit with 32 OS and 64 Bit with 64 OS.

Just figured I would share this information just in case someone experiences this in the future and is looking for an answer possibly why this is happening.
I also mentioned this to the developer.

Thank You